CVEvulnerability
CVE-2019-16762
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2019-11-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.7 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:H
- CVSS 2.0 ([email protected])
- 4.9 MEDIUM — AV:N/AC:M/Au:S/C:N/I:P/A:P
- Weaknesses
- CWE-20
Description
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.
Affected configurations
• simpleledger slpjs (< 0.21.4)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/simpleledger/slpjs/commit/ac8809b42e47790a6f0205991b36f2699ed10c84#diff-fe58606994c412ba56a65141a7aa4a62L701 Patch, Third Party Advisory
- https://github.com/simpleledger/slpjs/security/advisories/GHSA-425c-ccf3-3jrr Exploit, Patch, Third Party Advisory
- https://github.com/simpleledger/slpjs/commit/ac8809b42e47790a6f0205991b36f2699ed10c84#diff-fe58606994c412ba56a65141a7aa4a62L701 Patch, Third Party Advisory
- https://github.com/simpleledger/slpjs/security/advisories/GHSA-425c-ccf3-3jrr Exploit, Patch, Third Party Advisory