CVEvulnerability
CVE-2019-25158
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-12-19
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 5.2 MEDIUM — AV:A/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-78
Description
A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. This vulnerability affects the function onSpeechDone of the file app.js. The manipulation leads to os command injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 29d9c25415911ea2f8b6de247cb5c4607d13d434. It is recommended to upgrade the affected component. VDB-248278 is the identifier assigned to this vulnerability.
Affected configurations
• pedroetb tts-api (< 2.2.0)
Related
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://github.com/pedroetb/tts-api/commit/29d9c25415911ea2f8b6de247cb5c4607d13d434 Patch
- https://github.com/pedroetb/tts-api/releases/tag/v2.2.0 Release Notes
- https://vuldb.com/?ctiid.248278 Permissions Required
- https://vuldb.com/?id.248278 Third Party Advisory
- https://github.com/pedroetb/tts-api/commit/29d9c25415911ea2f8b6de247cb5c4607d13d434 Patch
- https://github.com/pedroetb/tts-api/releases/tag/v2.2.0 Release Notes
- https://vuldb.com/?ctiid.248278 Permissions Required
- https://vuldb.com/?id.248278 Third Party Advisory