CVEvulnerability
CVE-2019-3726
6.7 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2019-09-24
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.7 MEDIUM — CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- CVSS 3.0 ([email protected])
- 6.7 MEDIUM — CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.2 MEDIUM — AV:L/AC:H/Au:N/C:C/I:C/A:C
- Weaknesses
- CWE-427
Description
An Uncontrolled Search Path Vulnerability is applicable to the following: Dell Update Package (DUP) Framework file versions prior to 19.1.0.413, and Framework file versions prior to 103.4.6.69 used in Dell EMC Servers. Dell Update Package (DUP) Framework file versions prior to 3.8.3.67 used in Dell Client Platforms. The vulnerability is limited to the DUP framework during the time window when a DUP is being executed by an administrator. During this time window, a locally authenticated low privilege malicious user potentially could exploit this vulnerability by tricking an administrator into running a trusted binary, causing it to load a malicious DLL and allowing the attacker to execute arbitrary code on the victim system. The vulnerability does not affect the actual binary payload that the DUP delivers.
Affected configurations
• dell update package framework (< 3.8.3.67)
• dell update package framework (< 103.4.6.69)
• dell update package framework (< 19.1.0.413)
Related
Weakness · CWE (1)
- CWE-427 Uncontrolled Search Path Element weakness
References
- https://www.dell.com/support/article/SLN318693 Vendor Advisory
- https://www.dell.com/support/article/SLN318693 Vendor Advisory