CVEvulnerability
CVE-2019-5421
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2019-04-03
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-307, CWE-367
Description
Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.
Affected configurations
• plataformatec devise (<= 4.5.0)
Related
References
- https://github.com/plataformatec/devise/issues/4981 Exploit, Issue Tracking, Third Party Advisory
- https://github.com/plataformatec/devise/pull/4996 Patch, Third Party Advisory
- https://github.com/plataformatec/devise/issues/4981 Exploit, Issue Tracking, Third Party Advisory
- https://github.com/plataformatec/devise/pull/4996 Patch, Third Party Advisory