CVEvulnerability

CVE-2020-10018

9.8 CRITICAL Published 2020-03-02 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-03-02
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
Weaknesses
CWE-416

Description

WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.

Affected configurations

• webkitgtk webkitgtk (< 2.28.0) • wpewebkit wpe webkit (< 2.28.0) • fedoraproject fedora 30 • fedoraproject fedora 31 • debian debian linux 10.0 • canonical ubuntu linux 18.04 • canonical ubuntu linux 19.10 • opensuse leap 15.1

Related

Weakness · CWE (1)

References