CVEvulnerability
CVE-2020-10516
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2020-06-03
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-285, CWE-552
Description
An improper access control vulnerability was identified in the GitHub Enterprise Server API that allowed an organization member to escalate permissions and gain access to unauthorized repositories within an organization. This vulnerability affected all versions of GitHub Enterprise Server prior to 2.21 and was fixed in 2.20.9, 2.19.15, and 2.18.20. This vulnerability was reported via the GitHub Bug Bounty program.
Affected configurations
• github github (>= 2.18.0 < 2.18.20)
• github github (>= 2.19.0 < 2.19.15)
• github github (>= 2.20.0 < 2.20.9)
Related
References
- https://enterprise.github.com/releases/2.18.20/notes Release Notes, Third Party Advisory
- https://enterprise.github.com/releases/2.19.15/notes Release Notes, Third Party Advisory
- https://enterprise.github.com/releases/2.20.9/notes Release Notes, Third Party Advisory
- https://enterprise.github.com/releases/2.18.20/notes Release Notes, Third Party Advisory
- https://enterprise.github.com/releases/2.19.15/notes Release Notes, Third Party Advisory
- https://enterprise.github.com/releases/2.20.9/notes Release Notes, Third Party Advisory