CVEvulnerability
CVE-2020-11001
6.8 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2020-04-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 6.8 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
- CVSS 2.0 ([email protected])
- 3.5 LOW — AV:N/AC:M/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-79, CWE-80
Description
In Wagtail before versions 2.8.1 and 2.7.2, a cross-site scripting (XSS) vulnerability exists on the page revision
comparison view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail
admin could potentially craft a page revision history that, when viewed by a user with higher privileges, could perform
actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to
the Wagtail admin.
Patched versions have been released as Wagtail 2.7.2 (for the LTS 2.7 branch) and Wagtail 2.8.1 (for the current 2.8 branch).
Affected configurations
• torchbox wagtail (>= 1.9 <= 2.7.1)
• torchbox wagtail 2.8
Related
References
- https://github.com/wagtail/wagtail/security/advisories/GHSA-v2wc-pfq2-5cm6 Exploit, Third Party Advisory
- https://github.com/wagtail/wagtail/commit/61045ceefea114c40ac4b680af58990dbe732389 github.com
- https://github.com/wagtail/wagtail/releases/tag/v2.8.1 github.com
- https://github.com/wagtail/wagtail/security/advisories/GHSA-v2wc-pfq2-5cm6 Exploit, Third Party Advisory