CVEvulnerability
CVE-2020-11020
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2020-04-29
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-287
Description
Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.
Affected configurations
• faye project faye (> 0.5.0 < 1.0.4)
• faye project faye (>= 1.1.0 < 1.1.3)
• faye project faye (>= 1.2.0 < 1.2.5)
Related
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://github.com/faye/faye/commit/65d297d341b607f3cb0b5fa6021a625a991cc30e Patch, Third Party Advisory
- https://github.com/faye/faye/security/advisories/GHSA-qpg4-4w7w-2mq5 Exploit, Mitigation, Third Party Advisory
- https://github.com/faye/faye/commit/65d297d341b607f3cb0b5fa6021a625a991cc30e Patch, Third Party Advisory
- https://github.com/faye/faye/security/advisories/GHSA-qpg4-4w7w-2mq5 Exploit, Mitigation, Third Party Advisory