CVEvulnerability

CVE-2020-11027

8.1 HIGH Published 2020-04-30 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-04-30
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.1 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
CVSS 3.1 ([email protected])
8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
CVSS 2.0 ([email protected])
5.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:N
Weaknesses
CWE-640, CWE-672

Description

In affected versions of WordPress, a password reset link emailed to a user does not expire upon changing the user password. Access would be needed to the email account of the user by a malicious party for successful execution. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).

Affected configurations

• debian debian linux 8.0 • debian debian linux 9.0 • debian debian linux 10.0 • wordpress wordpress (>= 3.7 < 3.7.33) • wordpress wordpress (>= 3.8 < 3.8.33) • wordpress wordpress (>= 3.9 < 3.9.31) • wordpress wordpress (>= 4.0 < 4.0.30) • wordpress wordpress (>= 4.1 < 4.1.30) • wordpress wordpress (>= 4.2 < 4.2.27) • wordpress wordpress (>= 4.3 < 4.3.23) • wordpress wordpress (>= 4.4 < 4.4.22) • wordpress wordpress (>= 4.5 < 4.5.21) • wordpress wordpress (>= 4.6 < 4.6.18) • wordpress wordpress (>= 4.7 < 4.7.17) • wordpress wordpress (>= 4.8 < 4.8.13) • wordpress wordpress (>= 4.9 < 4.9.14) • wordpress wordpress (>= 5.0 < 5.0.9) • wordpress wordpress (>= 5.1 < 5.1.5) • wordpress wordpress (>= 5.2 < 5.2.6) • wordpress wordpress (>= 5.3 < 5.3.3) • wordpress wordpress 5.4

Related

Weakness · CWE (2)

  • CWE-640 Weak Password Recovery Mechanism for Forgotten Password weakness
  • CWE-672 Operation on a Resource after Expiration or Release weakness

References