CVEvulnerability

CVE-2020-11988

8.2 HIGH Published 2021-02-24 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2021-02-24
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
CVSS 2.0 ([email protected])
6.4 MEDIUM — AV:N/AC:L/Au:N/C:P/I:P/A:N
Weaknesses
CWE-20, CWE-918

Description

Apache XmlGraphics Commons 2.4 and earlier is vulnerable to server-side request forgery, caused by improper input validation by the XMPParser. By using a specially-crafted argument, an attacker could exploit this vulnerability to cause the underlying server to make arbitrary GET requests. Users should upgrade to 2.6 or later.

Affected configurations

• apache xmlgraphics commons (<= 2.4) • fedoraproject fedora 33 • fedoraproject fedora 34

Related

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-918 Server-Side Request Forgery weakness

References