CVEvulnerability
CVE-2020-15138
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2020-08-07
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:L
- CVSS 2.0 ([email protected])
- 2.6 LOW — AV:N/AC:H/Au:N/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.
Affected configurations
• prismjs previewers (>= 1.1.0 < 1.21.0)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/PrismJS/prism/pull/2506/commits/7bd7de05edf71112a3a77f87901a2409c9c5c20c Patch, Third Party Advisory
- https://github.com/PrismJS/prism/security/advisories/GHSA-wvhm-4hhf-97x9 Third Party Advisory
- https://prismjs.com/plugins/previewers/#disabling-a-previewer Vendor Advisory
- https://github.com/PrismJS/prism/pull/2506/commits/7bd7de05edf71112a3a77f87901a2409c9c5c20c Patch, Third Party Advisory
- https://github.com/PrismJS/prism/security/advisories/GHSA-wvhm-4hhf-97x9 Third Party Advisory
- https://prismjs.com/plugins/previewers/#disabling-a-previewer Vendor Advisory