CVEvulnerability
CVE-2020-15143
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2020-08-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.7 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-74, CWE-917
Description
In SyliusResourceBundle before versions 1.3.14, 1.4.7, 1.5.2 and 1.6.4, rrequest parameters injected inside an expression evaluated by `symfony/expression-language` package haven't been sanitized properly. This allows the attacker to access any public service by manipulating that request parameter, allowing for Remote Code Execution. This issue has been patched for versions 1.3.14, 1.4.7, 1.5.2 and 1.6.4. Versions prior to 1.3 were not patched.
Affected configurations
• sylius syliusresourcebundle (<= 1.3.13)
• sylius syliusresourcebundle (>= 1.4.0 <= 1.4.6)
• sylius syliusresourcebundle (>= 1.5.0 <= 1.5.1)
• sylius syliusresourcebundle (>= 1.6.0 <= 1.6.3)
Related
References
- https://github.com/Sylius/SyliusResourceBundle/security/advisories/GHSA-p4pj-9g59-4ppv Exploit, Mitigation, Third Party Advisory
- https://github.com/Sylius/SyliusResourceBundle/security/advisories/GHSA-p4pj-9g59-4ppv Exploit, Mitigation, Third Party Advisory