CVEvulnerability
CVE-2020-15148
10.0 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2020-09-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.9 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:H
- CVSS 3.1 ([email protected])
- 10.0 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-502
Description
Yii 2 (yiisoft/yii2) before version 2.0.38 is vulnerable to remote code execution if the application calls `unserialize()` on arbitrary user input. This is fixed in version 2.0.38. A possible workaround without upgrading is available in the linked advisory.
Affected configurations
• yiiframework yii (< 2.0.38)
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://github.com/yiisoft/yii2/commit/9abccb96d7c5ddb569f92d1a748f50ee9b3e2b99 Patch, Third Party Advisory
- https://github.com/yiisoft/yii2/security/advisories/GHSA-699q-wcff-g9mj Mitigation, Third Party Advisory
- https://github.com/yiisoft/yii2/commit/9abccb96d7c5ddb569f92d1a748f50ee9b3e2b99 Patch, Third Party Advisory
- https://github.com/yiisoft/yii2/security/advisories/GHSA-699q-wcff-g9mj Mitigation, Third Party Advisory