CVEvulnerability

CVE-2020-15150

9.8 CRITICAL Published 2020-09-01 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-09-01
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
9.0 CRITICAL — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
Weaknesses
CWE-94

Description

There is a vulnerability in Paginator (Elixir/Hex package) which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function. This will potentially affect all current users of Paginator prior to version 1.0.0. The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5.

Affected configurations

• duffel paginator (< 1.0.0)

Related

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References