CVEvulnerability
CVE-2020-15153
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2021-04-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-89
Description
Ampache before version 4.2.2 allows unauthenticated users to perform SQL injection. Refer to the referenced GitHub Security Advisory for details and a workaround. This is fixed in version 4.2.2 and the development branch.
Affected configurations
• ampache ampache (< 4.2.2)
Related
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://github.com/ampache/ampache/commit/e92cb6154c32c513b9c07e5fdbf5ac7de81ef5ed Patch, Third Party Advisory
- https://github.com/ampache/ampache/releases/tag/4.2.2 Release Notes, Third Party Advisory
- https://github.com/ampache/ampache/security/advisories/GHSA-phr3-mpx5-7826 Exploit, Mitigation, Third Party Advisory
- https://github.com/ampache/ampache/commit/e92cb6154c32c513b9c07e5fdbf5ac7de81ef5ed Patch, Third Party Advisory
- https://github.com/ampache/ampache/releases/tag/4.2.2 Release Notes, Third Party Advisory
- https://github.com/ampache/ampache/security/advisories/GHSA-phr3-mpx5-7826 Exploit, Mitigation, Third Party Advisory