CVEvulnerability
CVE-2020-15210
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2020-09-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H
- CVSS 2.0 ([email protected])
- 5.8 MEDIUM — AV:N/AC:M/Au:N/C:N/I:P/A:P
- Weaknesses
- CWE-20, CWE-787
Description
In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and will release patch releases for all versions between 1.15 and 2.3. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
Affected configurations
• google tensorflow (< 1.15.4)
• google tensorflow (>= 2.0.0 < 2.0.3)
• google tensorflow (>= 2.1.0 < 2.1.2)
• google tensorflow (>= 2.2.0 < 2.2.1)
• google tensorflow (>= 2.3.0 < 2.3.1)
• opensuse leap 15.2
Related
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html Mailing List, Third Party Advisory
- https://github.com/tensorflow/tensorflow/commit/d58c96946b2880991d63d1dacacb32f0a4dfa453 Patch, Third Party Advisory
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1 Third Party Advisory
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-x9j7-x98r-r4w2 Exploit, Third Party Advisory
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html Mailing List, Third Party Advisory
- https://github.com/tensorflow/tensorflow/commit/d58c96946b2880991d63d1dacacb32f0a4dfa453 Patch, Third Party Advisory
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1 Third Party Advisory
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-x9j7-x98r-r4w2 Exploit, Third Party Advisory