CVEvulnerability

CVE-2020-15240

9.1 CRITICAL Published 2020-10-21 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-10-21
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.4 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS 3.1 ([email protected])
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS 2.0 ([email protected])
5.8 MEDIUM — AV:N/AC:M/Au:N/C:P/I:P/A:N
Weaknesses
CWE-287, CWE-347

Description

omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.

Affected configurations

• auth0 omniauth-auth0 (>= 2.3.0 < 2.4.1)

Related

Weakness · CWE (2)

  • CWE-287 Improper Authentication weakness
  • CWE-347 Improper Verification of Cryptographic Signature weakness

References