CVEvulnerability
CVE-2020-15244
7.2 HIGH
Official page ↗
- Status
- Modified
- Published
- 2020-10-21
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.0 HIGH — CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-502, CWE-74
Description
In Magento (rubygems openmage/magento-lts package) before versions 19.4.8 and 20.0.4, an admin user can generate soap credentials that can be used to trigger RCE via PHP Object Injection through product attributes and a product. The issue is patched in versions 19.4.8 and 20.0.4.
Affected configurations
• openmage magento (<= 19.4.8)
• openmage magento (>= 20.0.0 < 20.0.4)
Related
References
- https://github.com/OpenMage/magento-lts/commit/26433d15b57978fcb7701b5f99efe8332ca8630b Patch, Vendor Advisory
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-jrgf-vfw2-hj26 Vendor Advisory
- https://github.com/OpenMage/magento-lts Vendor Advisory
- https://github.com/OpenMage/magento-lts/commit/26433d15b57978fcb7701b5f99efe8332ca8630b Patch, Vendor Advisory
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-jrgf-vfw2-hj26 Vendor Advisory