CVEvulnerability
CVE-2020-15269
9.1 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2020-10-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.4 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CVSS 2.0 ([email protected])
- 6.4 MEDIUM — AV:N/AC:L/Au:N/C:P/I:P/A:N
- Weaknesses
- CWE-287, CWE-613
Description
In Spree before versions 3.7.11, 4.0.4, or 4.1.11, expired user tokens could be used to access Storefront API v2 endpoints. The issue is patched in versions 3.7.11, 4.0.4 and 4.1.11. A workaround without upgrading is described in the linked advisory.
Affected configurations
• sparksolutions spree (< 3.7.11)
• sparksolutions spree (>= 4.0.0 < 4.0.4)
• sparksolutions spree (>= 4.1.0 < 4.1.11)
Related
Weakness · not in database (1)
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://github.com/spree/spree/commit/e43643abfe51f54bd9208dd02298b366e9b9a847 Patch, Third Party Advisory
- https://github.com/spree/spree/security/advisories/GHSA-f8cm-364f-q9qh Third Party Advisory
- https://github.com/spree/spree/commit/e43643abfe51f54bd9208dd02298b366e9b9a847 Patch, Third Party Advisory
- https://github.com/spree/spree/security/advisories/GHSA-f8cm-364f-q9qh Third Party Advisory