CVEvulnerability

CVE-2020-15704

5.5 MEDIUM Published 2020-09-01 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-09-01
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 3.1 ([email protected])
5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0 ([email protected])
2.1 LOW — AV:L/AC:L/Au:N/C:P/I:N/A:N
Weaknesses
CWE-20, CWE-200

Description

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

Affected configurations

• canonical ppp (< 2.4.7-1\+ubuntu1.16.04.3) • canonical ppp (< 2.4.7-2\+2ubuntu1.3) • canonical ppp (< 2.4.7-2\+4.1ubuntu5.1) • canonical ppp (< 2.4.5-5ubuntu1.4) • canonical ppp (< 2.4.5-5.1ubuntu2.3\+esm2)

Related

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References