CVEvulnerability
CVE-2020-15720
6.8 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2020-07-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:H/Au:N/C:P/I:P/A:N
- Weaknesses
- CWE-295
Description
In Dogtag PKI through 10.8.3, the pki.client.PKIConnection class did not enable python-requests certificate validation. Since the verify parameter was hard-coded in all request functions, it was not possible to override the setting. As a result, tools making use of this class, such as the pki-server command, may have been vulnerable to Person-in-the-Middle attacks in certain non-localhost use cases. This is fixed in 10.9.0-b1.
Affected configurations
• dogtagpki dogtagpki (<= 10.8.3)
Related
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1855273 Issue Tracking, Patch, Third Party Advisory
- https://github.com/dogtagpki/pki/commit/50c23ec146ee9abf28c9de87a5f7787d495f0b72 Patch, Third Party Advisory
- https://github.com/dogtagpki/pki/compare/v10.9.0-a2...v10.9.0-b1 Patch, Third Party Advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=1855273 Issue Tracking, Patch, Third Party Advisory
- https://github.com/dogtagpki/pki/commit/50c23ec146ee9abf28c9de87a5f7787d495f0b72 Patch, Third Party Advisory
- https://github.com/dogtagpki/pki/compare/v10.9.0-a2...v10.9.0-b1 Patch, Third Party Advisory