CVEvulnerability
CVE-2020-24742
7.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2021-08-09
- Last modified
- 2026-10-08
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.8 MEDIUM — AV:N/AC:M/Au:N/C:P/I:P/A:P
Description
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
Affected configurations
• qt qt (>= 5.6.0 < 5.12.7)
• qt qt (>= 5.13.0 <= 5.13.2)
References
- https://codereview.qt-project.org/c/qt/qtbase/+/280730 Patch, Vendor Advisory
- https://codereview.qt-project.org/c/qt/qtbase/+/280730 Patch, Vendor Advisory