CVEvulnerability
CVE-2020-25629
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2020-12-08
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-284, CWE-862
Description
A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Affected configurations
• moodle moodle (>= 3.5.0 < 3.5.14)
• moodle moodle (>= 3.7.0 < 3.7.8)
• moodle moodle (>= 3.8.0 < 3.8.5)
• moodle moodle (>= 3.9.0 < 3.9.2)
Related
References
- https://moodle.org/mod/forum/discuss.php?d=410841 Patch, Vendor Advisory
- https://moodle.org/mod/forum/discuss.php?d=410841 Patch, Vendor Advisory