CVEvulnerability
CVE-2020-25630
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2020-12-08
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P
- Weaknesses
- CWE-400
Description
A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Affected configurations
• moodle moodle (>= 3.5.0 < 3.5.14)
• moodle moodle (>= 3.7.0 < 3.7.8)
• moodle moodle (>= 3.8.0 < 3.8.5)
• moodle moodle (>= 3.9.0 < 3.9.2)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://moodle.org/mod/forum/discuss.php?d=410842 Patch, Vendor Advisory
- https://moodle.org/mod/forum/discuss.php?d=410842 Patch, Vendor Advisory