CVEvulnerability

CVE-2020-25699

7.5 HIGH Published 2020-11-19 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-11-19
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0 ([email protected])
5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:P/A:N
Weaknesses
CWE-863

Description

In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Affected configurations

• moodle moodle (>= 3.5.0 <= 3.5.14) • moodle moodle (>= 3.7.0 <= 3.7.8) • moodle moodle (>= 3.8.0 <= 3.8.5) • moodle moodle (>= 3.9.0 <= 3.9.2) • fedoraproject fedora 32 • fedoraproject fedora 33

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References