CVEvulnerability
CVE-2020-26223
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2020-11-13
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.7 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:P/I:N/A:N
- Weaknesses
- CWE-863
Description
Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.
Affected configurations
• spreecommerce spree (>= 3.7.0 < 3.7.13)
• spreecommerce spree (>= 4.0.0 < 4.0.5)
• spreecommerce spree (>= 4.1.0 < 4.1.12)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://github.com/spree/spree/pull/10573 Exploit, Patch, Third Party Advisory
- https://github.com/spree/spree/security/advisories/GHSA-m2jr-hmc3-qmpr Third Party Advisory
- https://guides.spreecommerce.org/api/v2/storefront#tag/Order-Status Vendor Advisory
- https://github.com/spree/spree/pull/10573 Exploit, Patch, Third Party Advisory
- https://github.com/spree/spree/security/advisories/GHSA-m2jr-hmc3-qmpr Third Party Advisory
- https://guides.spreecommerce.org/api/v2/storefront#tag/Order-Status Vendor Advisory