CVEvulnerability

CVE-2020-4043

9.8 CRITICAL Published 2020-06-10 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-06-10
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.7 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
Weaknesses
CWE-502

Description

phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.

Affected configurations

• phpmussel project phpmussel (>= 1.0.0 < 1.6.0)

Related

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References