CVEvulnerability

CVE-2020-4047

6.8 MEDIUM Published 2020-06-12 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-06-12
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.8 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N
CVSS 3.1 ([email protected])
6.8 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N
CVSS 2.0 ([email protected])
3.5 LOW — AV:N/AC:M/Au:S/C:N/I:P/A:N
Weaknesses
CWE-80

Description

In affected versions of WordPress, authenticated users with upload permissions (like authors) are able to inject JavaScript into some media file attachment pages in a certain way. This can lead to script execution in the context of a higher privileged user when the file is viewed by them. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

Affected configurations

• wordpress wordpress (>= 3.7 < 3.7.34) • wordpress wordpress (>= 3.8 < 3.8.34) • wordpress wordpress (>= 3.9 < 3.9.32) • wordpress wordpress (>= 4.0 < 4.0.31) • wordpress wordpress (>= 4.1 < 4.1.31) • wordpress wordpress (>= 4.2 < 4.2.28) • wordpress wordpress (>= 4.3 < 4.3.24) • wordpress wordpress (>= 4.4 < 4.4.23) • wordpress wordpress (>= 4.5 < 4.5.22) • wordpress wordpress (>= 4.6 < 4.6.19) • wordpress wordpress (>= 4.7 < 4.7.18) • wordpress wordpress (>= 4.8 < 4.8.14) • wordpress wordpress (>= 4.9 < 4.9.15) • wordpress wordpress (>= 5.0 < 5.0.10) • wordpress wordpress (>= 5.1 < 5.1.6) • wordpress wordpress (>= 5.2 < 5.2.7) • wordpress wordpress (>= 5.3.0 < 5.3.4) • wordpress wordpress (>= 5.4 < 5.4.2) • fedoraproject fedora 32 • fedoraproject fedora 33 • debian debian linux 8.0 • debian debian linux 9.0 • debian debian linux 10.0

Related

Weakness · CWE (1)

  • CWE-80 Improper Neutralization of Script-Related HTML Tags in a Web Page weakness

References