CVEvulnerability
CVE-2020-5216
5.8 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2020-01-23
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.4 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 5.8 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:P/A:N
- Weaknesses
- CWE-113, CWE-74
Description
In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.9.0, 5.2.0, and 6.3.0. If user-supplied input was passed into append/override_content_security_policy_directives, a newline could be injected leading to limited header injection. Upon seeing a newline in the header, rails will silently create a new Content-Security-Policy header with the remaining value of the original string. It will continue to create new headers for each newline. This has been fixed in 6.3.0, 5.2.0, and 3.9.0.
Affected configurations
• twitter secure headers (< 3.9.0)
• twitter secure headers (>= 5.0.0 < 5.2.0)
• twitter secure headers (>= 6.0.0 < 6.3.0)
Related
References
- https://github.com/twitter/secure_headers/commit/301695706f6a70517c2a90c6ef9b32178440a2d0 Patch
- https://github.com/twitter/secure_headers/security/advisories/GHSA-w978-rmpf-qmwg Exploit, Mitigation, Third Party Advisory
- https://github.com/twitter/secure_headers/commit/301695706f6a70517c2a90c6ef9b32178440a2d0 Patch
- https://github.com/twitter/secure_headers/security/advisories/GHSA-w978-rmpf-qmwg Exploit, Mitigation, Third Party Advisory