CVEvulnerability

CVE-2020-5217

5.8 MEDIUM Published 2020-01-23 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-01-23
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
4.4 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.1 ([email protected])
5.8 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
CVSS 2.0 ([email protected])
5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:P/A:N
Weaknesses
CWE-74, CWE-95

Description

In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.8.0, 5.1.0, and 6.2.0. If user-supplied input was passed into append/override_content_security_policy_directives, a semicolon could be injected leading to directive injection. This could be used to e.g. override a script-src directive. Duplicate directives are ignored and the first one wins. The directives in secure_headers are sorted alphabetically so they pretty much all come before script-src. A previously undefined directive would receive a value even if SecureHeaders::OPT_OUT was supplied. The fixed versions will silently convert the semicolons to spaces and emit a deprecation warning when this happens. This will result in innocuous browser console messages if being exploited/accidentally used. In future releases, we will raise application errors resulting in 500s. Depending on what major version you are using, the fixed versions are 6.2.0, 5.1.0, 3.8.0.

Affected configurations

• twitter secure headers (< 3.8.0) • twitter secure headers (>= 5.0.0 < 5.1.0) • twitter secure headers (>= 6.0.0 < 6.2.0)

Related

Weakness · CWE (2)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
  • CWE-95 Improper Neutralization of Directives in Dynamically Evaluated Code weakness

References