CVEvulnerability
CVE-2020-5263
4.9 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2020-04-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:P/I:N/A:N
- Weaknesses
- CWE-522
Description
auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3
Affected configurations
• auth0 auth0.js (>= 8.0.0 <= 9.13.1)
Related
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness
References
- https://github.com/auth0/auth0.js/commit/355ca749b229fb93142f0b3978399b248d710828 Patch, Third Party Advisory
- https://github.com/auth0/auth0.js/security/advisories/GHSA-prfq-f66g-43mp Third Party Advisory
- https://github.com/auth0/auth0.js/commit/355ca749b229fb93142f0b3978399b248d710828 Patch, Third Party Advisory
- https://github.com/auth0/auth0.js/security/advisories/GHSA-prfq-f66g-43mp Third Party Advisory