CVEvulnerability

CVE-2020-5291

7.8 HIGH Published 2020-03-31 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-03-31
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.2 HIGH — CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
CVSS 3.1 ([email protected])
7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
8.5 HIGH — AV:N/AC:M/Au:S/C:C/I:C/A:C
Weaknesses
CWE-269, CWE-648

Description

Bubblewrap (bwrap) before version 0.4.1, if installed in setuid mode and the kernel supports unprivileged user namespaces, then the `bwrap --userns2` option can be used to make the setuid process keep running as root while being traceable. This can in turn be used to gain root permissions. Note that this only affects the combination of bubblewrap in setuid mode (which is typically used when unprivileged user namespaces are not supported) and the support of unprivileged user namespaces. Known to be affected are: * Debian testing/unstable, if unprivileged user namespaces enabled (not default) * Debian buster-backports, if unprivileged user namespaces enabled (not default) * Arch if using `linux-hardened`, if unprivileged user namespaces enabled (not default) * Centos 7 flatpak COPR, if unprivileged user namespaces enabled (not default) This has been fixed in the 0.4.1 release, and all affected users should update.

Affected configurations

• projectatomic bubblewrap (< 0.4.1) • debian debian linux 10.0 • archlinux arch linux • centos centos 7.0

Related

Weakness · CWE (2)

  • CWE-269 Improper Privilege Management weakness
  • CWE-648 Incorrect Use of Privileged APIs weakness

References