CVEvulnerability
CVE-2020-8904
9.6 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2020-08-12
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.4 MEDIUM — CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:H
- CVSS 3.1 ([email protected])
- 9.6 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H
- CVSS 2.0 ([email protected])
- 5.5 MEDIUM — AV:N/AC:L/Au:S/C:N/I:P/A:P
- Weaknesses
- CWE-119, CWE-823
Description
An arbitrary memory overwrite vulnerability in the trusted memory of Asylo exists in versions prior to 0.6.0. As the ecall_restore function fails to validate the range of the output_len pointer, an attacker can manipulate the tmp_output_len value and write to an arbitrary location in the trusted (enclave) memory. We recommend updating Asylo to version 0.6.0 or later.
Affected configurations
• google asylo (< 0.6.0)
Related
References
- https://github.com/google/asylo/commit/e582f36ac49ee11a21d23ad6a30c333092e0a94e Patch, Third Party Advisory
- https://github.com/google/asylo/commit/e582f36ac49ee11a21d23ad6a30c333092e0a94e Patch, Third Party Advisory