CVEvulnerability

CVE-2020-8927

6.5 MEDIUM Published 2020-09-15 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2020-09-15
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
CVSS 2.0 ([email protected])
6.4 MEDIUM — AV:N/AC:L/Au:N/C:N/I:P/A:P
Weaknesses
CWE-120, CWE-130

Description

A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.

Affected configurations

• google brotli (< 1.0.8) • debian debian linux 9.0 • debian debian linux 10.0 • fedoraproject fedora 31 • fedoraproject fedora 32 • fedoraproject fedora 33 • fedoraproject fedora 34 • fedoraproject fedora 35 • fedoraproject fedora 36 • canonical ubuntu linux 16.04 • canonical ubuntu linux 18.04 • canonical ubuntu linux 20.04 • opensuse leap 15.2 • microsoft .net (>= 5.0 <= 5.0.14) • microsoft .net core (>= 3.1 <= 3.1.22) • microsoft powershell (>= 7.0 < 7.0.9) • microsoft powershell (>= 7.1 < 7.1.6) • microsoft powershell (>= 7.2 < 7.2.2) • microsoft visual studio 2019 (>= 16.0 <= 16.11) • microsoft visual studio 2022 (>= 17.0 <= 17.0.7) • microsoft visual studio 2022 17.1

Related

Weakness · CWE (2)

  • CWE-120 Buffer Copy without Checking Size of Input weakness
  • CWE-130 Improper Handling of Length Parameter Inconsistency weakness

References