CVEvulnerability
CVE-2021-21242
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2021-01-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 10.0 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-502, CWE-74
Description
OneDev is an all-in-one devops platform. In OneDev before version 4.0.3, there is a critical vulnerability which can lead to pre-auth remote code execution. AttachmentUploadServlet deserializes untrusted data from the `Attachment-Support` header. This Servlet does not enforce any authentication or authorization checks. This issue may lead to pre-auth remote code execution. This issue was fixed in 4.0.3 by removing AttachmentUploadServlet and not using deserialization
Affected configurations
• onedev project onedev (< 4.0.3)
Related
References
- https://github.com/theonedev/onedev/commit/f864053176c08f59ef2d97fea192ceca46a4d9be Patch, Third Party Advisory
- https://github.com/theonedev/onedev/security/advisories/GHSA-5q3q-f373-2jv8 Third Party Advisory
- https://github.com/theonedev/onedev/commit/f864053176c08f59ef2d97fea192ceca46a4d9be Patch, Third Party Advisory
- https://github.com/theonedev/onedev/security/advisories/GHSA-5q3q-f373-2jv8 Third Party Advisory