CVEvulnerability

CVE-2021-21252

7.5 HIGH Published 2021-01-13 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2021-01-13
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0 ([email protected])
5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P
Weaknesses
CWE-400

Description

The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.

Affected configurations

• jqueryvalidation jquery validation (< 1.19.3) • netapp snapcenter

Related

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References