CVEvulnerability
CVE-2021-21281
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2021-06-18
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.0 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-120
Description
Contiki-NG is an open-source, cross-platform operating system for internet of things devices. A buffer overflow vulnerability exists in Contiki-NG versions prior to 4.6. After establishing a TCP socket using the tcp-socket library, it is possible for the remote end to send a packet with a data offset that is unvalidated. The problem has been patched in Contiki-NG 4.6. Users can apply the patch for this vulnerability out-of-band as a workaround.
Affected configurations
• contiki-ng contiki-ng (< 4.6)
Related
Weakness · CWE (1)
- CWE-120 Buffer Copy without Checking Size of Input weakness
References
- https://github.com/contiki-ng/contiki-ng/pull/1366 Patch, Third Party Advisory
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-mc42-fqfr-h9fp Patch, Third Party Advisory
- https://github.com/contiki-ng/contiki-ng/pull/1366 Patch, Third Party Advisory
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-mc42-fqfr-h9fp Patch, Third Party Advisory