CVEvulnerability
CVE-2021-21297
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-02-26
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.7 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-1321, CWE-915
Description
Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier contains a Prototype Pollution vulnerability in the admin API. A badly formed request can modify the prototype of the default JavaScript Object with the potential to affect the default behaviour of the Node-RED runtime. The vulnerability is patched in the 1.2.8 release. A workaround is to ensure only authorized users are able to access the editor url.
Affected configurations
• nodered node-red (< 1.2.8)
Related
References
- https://github.com/node-red/node-red/releases/tag/1.2.8 Release Notes, Third Party Advisory
- https://github.com/node-red/node-red/security/advisories/GHSA-xp9c-82x8-7f67 Third Party Advisory
- https://www.npmjs.com/package/%40node-red/editor-api www.npmjs.com
- https://www.npmjs.com/package/%40node-red/runtime www.npmjs.com
- https://github.com/node-red/node-red/releases/tag/1.2.8 Release Notes, Third Party Advisory
- https://github.com/node-red/node-red/security/advisories/GHSA-xp9c-82x8-7f67 Third Party Advisory
- https://www.npmjs.com/package/%40node-red/editor-api www.npmjs.com
- https://www.npmjs.com/package/%40node-red/runtime www.npmjs.com