CVEvulnerability

CVE-2021-21311

7.2 HIGH Known exploited Published 2021-02-11 Modified 2026-06-17 Official page ↗

CISA Known Exploited Vulnerability

Adminer Server-Side Request Forgery Vulnerability — Adminer Adminer

Adminer contains a server-side request forgery vulnerability that, when exploited, allows a remote attacker to obtain potentially sensitive information.

Added to KEV
2025-09-29
Remediation due
2025-10-20
Ransomware use
Unknown
Required action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Notes
https://github.com/vrana/adminer/security/advisories/GHSA-x5r2-hj5c-8jx6 ; https://nvd.nist.gov/vuln/detail/CVE-2021-21311
Status
Analyzed
Published
2021-02-11
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS 3.1 ([email protected])
7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS 2.0 ([email protected])
6.4 MEDIUM — AV:N/AC:L/Au:N/C:P/I:P/A:N
Weaknesses
CWE-918

Description

Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

Affected configurations

• adminer adminer (>= 4.0.0 < 4.7.9) • debian debian linux 9.0

Related

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References