CVEvulnerability

CVE-2021-21391

6.5 MEDIUM Published 2021-04-29 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2021-04-29
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0 ([email protected])
4.3 MEDIUM — AV:N/AC:M/Au:N/C:N/I:N/A:P
Weaknesses
CWE-400

Description

CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem has been recognized and patched. The fix will be available in version 27.0.0.

Affected configurations

• ckeditor ckeditor5-engine (< 27.0.0) • ckeditor ckeditor5-font (< 27.0.0) • ckeditor ckeditor5-image (< 27.0.0) • ckeditor ckeditor5-list (< 27.0.0) • ckeditor ckeditor5-markdown-gfm (< 27.0.0) • ckeditor ckeditor5-media-embed (< 27.0.0) • ckeditor ckeditor5-paste-from-office (< 27.0.0) • ckeditor ckeditor5-widget (< 27.0.0)

Related

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References