CVEvulnerability

CVE-2021-22051

6.5 MEDIUM Published 2021-11-08 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2021-11-08
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0 ([email protected])
4.0 MEDIUM — AV:N/AC:L/Au:S/C:N/I:P/A:N
Weaknesses
CWE-863

Description

Applications using Spring Cloud Gateway are vulnerable to specifically crafted requests that could make an extra request on downstream services. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.5+, 2.2.x users should upgrade to 2.2.10.RELEASE or newer.

Affected configurations

• vmware spring cloud gateway (< 2.2.10) • vmware spring cloud gateway (>= 3.0.0 < 3.0.5)

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References