CVEvulnerability
CVE-2021-25642
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-08-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
Description
ZKConfigurationStore which is optionally used by CapacityScheduler of Apache Hadoop YARN deserializes data obtained from ZooKeeper without validation. An attacker having access to ZooKeeper can run arbitrary commands as YARN user by exploiting this. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.4 or later (containing YARN-11126) if ZKConfigurationStore is used.
Affected configurations
• apache hadoop (>= 2.9.0 < 2.10.2)
• apache hadoop (>= 3.0.0 < 3.2.4)
• apache hadoop (>= 3.3.0 < 3.3.4)
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://lists.apache.org/thread/g6vf2h4wdgzzdgk91mqozhs58wotq150 Mailing List, Vendor Advisory
- https://security.netapp.com/advisory/ntap-20221201-0003/ Third Party Advisory
- https://lists.apache.org/thread/g6vf2h4wdgzzdgk91mqozhs58wotq150 Mailing List, Vendor Advisory
- https://security.netapp.com/advisory/ntap-20221201-0003/ Third Party Advisory