CVEvulnerability
CVE-2021-27098
8.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2021-03-05
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CVSS 2.0 ([email protected])
- 5.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:N
- Weaknesses
- CWE-295
Description
In SPIRE 0.8.1 through 0.8.4 and before versions 0.9.4, 0.10.2, 0.11.3 and 0.12.1, specially crafted requests to the FetchX509SVID RPC of SPIRE Server’s Legacy Node API can result in the possible issuance of an X.509 certificate with a URI SAN for a SPIFFE ID that the agent is not authorized to distribute. Proper controls are in place to require that the caller presents a valid agent certificate that is already authorized to issue at least one SPIFFE ID, and the requested SPIFFE ID belongs to the same trust domain, prior to being able to trigger this vulnerability. This issue has been fixed in SPIRE versions 0.8.5, 0.9.4, 0.10.2, 0.11.3 and 0.12.1.
Affected configurations
• cncf spire (>= 0.8.1 <= 0.8.4)
• cncf spire (>= 0.9.0 < 0.9.4)
• cncf spire (>= 0.10.0 < 0.10.2)
• cncf spire (>= 0.11.0 < 0.11.3)
• cncf spire (>= 0.12.0 < 0.12.1)
Related
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://github.com/spiffe/spire/security/advisories/GHSA-h746-rm5q-8mgq Third Party Advisory
- https://github.com/spiffe/spire/security/advisories/GHSA-h746-rm5q-8mgq Third Party Advisory