CVEvulnerability

CVE-2021-27292

7.5 HIGH Published 2021-03-17 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2021-03-17
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0 ([email protected])
5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P

Description

ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.

Affected configurations

• ua-parser-js project ua-parser-js (>= 0.7.14 < 0.7.24)

References