CVEvulnerability
CVE-2021-29506
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-05-13
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:N/I:N/A:P
- Weaknesses
- CWE-400
Description
GraphHopper is an open-source Java routing engine. In GrassHopper from version 2.0 and before version 2.4, there is a regular expression injection vulnerability that may lead to Denial of Service. This has been patched in 2.4 and 3.0 See this pull request for the fix: https://github.com/graphhopper/graphhopper/pull/2304
Affected configurations
• graphhopper graphhopper (>= 2.0 < 2.4)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://github.com/graphhopper/graphhopper/commit/eb189be1fa7443ebf4ae881e737a18f818c95f41 Patch, Third Party Advisory
- https://github.com/graphhopper/graphhopper/pull/2304 Patch, Third Party Advisory
- https://github.com/graphhopper/graphhopper/security/advisories/GHSA-hf44-3mx6-vhhw Third Party Advisory
- https://github.com/graphhopper/graphhopper/commit/eb189be1fa7443ebf4ae881e737a18f818c95f41 Patch, Third Party Advisory
- https://github.com/graphhopper/graphhopper/pull/2304 Patch, Third Party Advisory
- https://github.com/graphhopper/graphhopper/security/advisories/GHSA-hf44-3mx6-vhhw Third Party Advisory