CVEvulnerability
CVE-2021-32268
7.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2021-09-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.8 MEDIUM — AV:N/AC:M/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-787
Description
Buffer overflow vulnerability in function gf_fprintf in os_file.c in gpac before 1.0.1 allows attackers to execute arbitrary code. The fixed version is 1.0.1.
Affected configurations
• gpac gpac (< 1.0.1)
Related
Weakness · CWE (1)
- CWE-787 Out-of-bounds Write weakness
References
- https://github.com/gpac/gpac/commit/388ecce75d05e11fc8496aa4857b91245007d26e Patch, Third Party Advisory
- https://github.com/gpac/gpac/issues/1587 Exploit, Issue Tracking, Patch, Third Party Advisory
- https://github.com/gpac/gpac/commit/388ecce75d05e11fc8496aa4857b91245007d26e Patch, Third Party Advisory
- https://github.com/gpac/gpac/issues/1587 Exploit, Issue Tracking, Patch, Third Party Advisory