CVEvulnerability
CVE-2021-32666
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-06-03
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:N/I:N/A:P
- Weaknesses
- CWE-20
Description
wire-ios is the iOS version of Wire, an open-source secure messaging app. In wire-ios versions 3.8.0 and prior, a vulnerability exists that can cause a denial of service between users. If a user has an invalid assetID for their profile picture and it contains the " character, it will cause the iOS client to crash. The vulnerability is patched in wire-ios version 3.8.1.
Affected configurations
• wire wire (< 3.81)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/wireapp/wire-ios-data-model/commit/35af3f632085f51a2ce7f608fdaeffd1a69ad89f Patch, Third Party Advisory
- https://github.com/wireapp/wire-ios/security/advisories/GHSA-2x9x-vh27-h4rv Patch, Third Party Advisory
- https://github.com/wireapp/wire-ios-data-model/commit/35af3f632085f51a2ce7f608fdaeffd1a69ad89f Patch, Third Party Advisory
- https://github.com/wireapp/wire-ios/security/advisories/GHSA-2x9x-vh27-h4rv Patch, Third Party Advisory