CVEvulnerability
CVE-2021-32702
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-06-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.0 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.3 MEDIUM — AV:N/AC:M/Au:N/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.
Affected configurations
• auth0 nextjs-auth0 (< 1.4.2)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/auth0/nextjs-auth0/commit/6996e2528ceed98627caa28abafbc09e90163ccf Patch, Third Party Advisory
- https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-954c-jjx6-cxv7 Third Party Advisory
- https://www.npmjs.com/package/%40auth0/nextjs-auth0 www.npmjs.com
- https://github.com/auth0/nextjs-auth0/commit/6996e2528ceed98627caa28abafbc09e90163ccf Patch, Third Party Advisory
- https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-954c-jjx6-cxv7 Third Party Advisory
- https://www.npmjs.com/package/%40auth0/nextjs-auth0 www.npmjs.com