CVEvulnerability
CVE-2021-32782
5.4 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-09-07
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 3.5 LOW — AV:N/AC:M/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
Nextcloud Circles is an open source social network built for the nextcloud ecosystem. In affected versions the Nextcloud Circles application is vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Circles application is upgraded to 0.21.3, 0.20.10 or 0.19.14 to resolve this issue. As a workaround users may use a browser that has support for Content-Security-Policy. A notable exemption is Internet Explorer which does not support CSP properly.
Affected configurations
• nextcloud circles (< 0.19.14)
• nextcloud circles (>= 0.20.0 < 0.20.10)
• nextcloud circles (>= 0.21.0 < 0.21.3)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/nextcloud/circles/commit/dbb97a83ccb342c839a54f088aa19b8ba6844b0e Patch, Third Party Advisory
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-hgpq-28gj-jrj9 Patch, Third Party Advisory
- https://hackerone.com/reports/1217606 Permissions Required, Third Party Advisory
- https://github.com/nextcloud/circles/commit/dbb97a83ccb342c839a54f088aa19b8ba6844b0e Patch, Third Party Advisory
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-hgpq-28gj-jrj9 Patch, Third Party Advisory
- https://hackerone.com/reports/1217606 Permissions Required, Third Party Advisory