CVEvulnerability
CVE-2021-32800
8.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2021-09-07
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CVSS 2.0 ([email protected])
- 6.4 MEDIUM — AV:N/AC:L/Au:N/C:P/I:P/A:N
- Weaknesses
- CWE-306
Description
Nextcloud server is an open source, self hosted personal cloud. In affected versions an attacker is able to bypass Two Factor Authentication in Nextcloud. Thus knowledge of a password, or access to a WebAuthN trusted device of a user was sufficient to gain access to an account. It is recommended that the Nextcloud Server is upgraded to 20.0.12, 21.0.4 or 22.1.0. There are no workaround for this vulnerability.
Affected configurations
• nextcloud nextcloud server (< 20.0.12)
• nextcloud nextcloud server (>= 21.0.0 < 21.0.4)
• nextcloud nextcloud server (>= 22.0.0 < 22.1.0)
Related
Weakness · CWE (1)
- CWE-306 Missing Authentication for Critical Functionality weakness
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-gv5w-8q25-785v Third Party Advisory
- https://github.com/nextcloud/server/pull/28078 Patch, Third Party Advisory
- https://hackerone.com/reports/1271052 Permissions Required, Third Party Advisory
- https://security.gentoo.org/glsa/202208-17 Third Party Advisory
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-gv5w-8q25-785v Third Party Advisory
- https://github.com/nextcloud/server/pull/28078 Patch, Third Party Advisory
- https://hackerone.com/reports/1271052 Permissions Required, Third Party Advisory
- https://security.gentoo.org/glsa/202208-17 Third Party Advisory